1 (edited by carlosalvatore 2019-02-26 19:17:06)

Topic: Known problem: openrc udev-trigger disables video (laptop screen)


This problem seems to be already know in other distros with this hardware (Mini laptop Asus EeePc 1025C).

When udev-trigger launches at sysinit, screen goes black and stays like that for a long time. If you connect the computer to an external monitor (HDMI, for instance) it works, but the laptop screen remains off no matter what.

I had disabled udev-trigger, which allowed the computer to boot OK, with the screen working fine. You can even load the video module (gma500_gfx) using modprobe. Yet, a lot of problems rise when starting the GUI of the desktop environment (xfce in my case), like not having input devices.

I know it is possible to enable stuff by hand; but this behavior shouldn't occur. It happened when installing from the live CD too. Which almost discouraged me from installing.

Video card is detected as Atom Processor D2xxx/N2xxx Integrated graphics controller.

How can I possible fix this?

2 (edited by carlosalvatore 2019-02-26 19:16:52)

Re: Known problem: openrc udev-trigger disables video (laptop screen)

More info: when I don't use udev-trigger and load some module call wmi, the screen goes black.

I have tried to change the backlight in /sys/class/backlight but it is at its maximum value already.

I hope any of you could help. I had googled the problem but I couldn't find anything that points into the right direction, there is the usual nonsense about sending parameters to the kernel using grub, but that didn't work. Also, screen is fine at boot, so the problem has to be caused by some module (or modules), most likely wmi or something it launches.  I had also tried to launch the modules that depend on wmi, and they don't crash.

dmesg and /var/log/messages show nothing unusual.

3 (edited by carlosalvatore 2019-02-26 22:19:32)

Re: Known problem: openrc udev-trigger disables video (laptop screen)

Hi again,

for any of you who ran into the same problem. I managed to make it work by disabling udev-trigger and starting my working modules with the openrc init script for modules.

edit /etc/conf.d/modules and add a line like:

modules="foo bar"

where foo and bar are all your modules. The list can be long, but you can use line escapes (\)

modules="foo1 foo2 foo3 foo4 \
foo5 foo6 bar1 bar2 bar3 bar4"

Then, I fixed my init level. I had added modules and udev to the sysinit runlevel, dbus and elogind to the boot runlevel and acpid to the default one.

Thus, I was able to run X with xfce.

It does not solve the problem per se, but is a workaround.
Hope it can help someone.


Re: Known problem: openrc udev-trigger disables video (laptop screen)

Try adding nomodeset as a kernel parameter - it should provide basic functional graphics.


Re: Known problem: openrc udev-trigger disables video (laptop screen)

eudev is the default for geentoo instead of udev, so you might want to try eudev instead given opnrc is maintained by gentoo.