Topic: Can't access Android phone with mtp

The phone is a Coolpad, Android version 4.4.4. I can access it on Debian Linux (same laptop, different partition), on which the same version of libmtp is installed. According to libmtp's sourceforge page, Coolpads are supported: https://sourceforge.net/p/libmtp/code/c … -players.h

If I try mtp-detect just after starting up Hyperbola with the phone attached (USB), the phone is detected, but connection fails. Any other time, mtp-detect gives me "No raw devices found."

If I start android-file-transfer, I get a pop-up dialog with the error "No MTP device found".

lsusb shows the device is detected, but doesn't display any vendor information. It is simply listed as

Bus 002 Device 006: ID 1ebf:7f2c


I've tried restarting the phone, using different USB outlets, and turning USB debugging off and on.


Re: Can't access Android phone with mtp

Although likely to cause me more answers than questions, it seems that if I switch from tty1 and any other session and back to tty1, then android-file-transfer magically starts working. I'm also running Fluxbox without a graphical login, so who knows. So maybe, for now, what happens if you switch between sessions (presumably via ctrl-alt-F*)?


Re: Can't access Android phone with mtp

Weird. It worked. How did you find that trick?

4 (edited by outtasight 2019-07-01 00:03:29)

Re: Can't access Android phone with mtp

While trying to figure out why I can't seem to run `android-file-transfer` either, I switched over to tty12 to run `mtp-detect` as root.

However, after some more investigating and/or fooling around, it appears that tty switching is (probably) more of an exploit than it is a workaround. While (re)installing  `android-udev`, I noticed it mentions:

WARNING: Users need to be in 'adbusers' and 'uucp' groups to connect to Android devices:

Adding myself to the 'adbusers' group seems to allow me to run `android-file-transfer` without any issues now. Being part of the 'uucp' doesn't at this time seem be needed, but if that's what a package recommends, I'm going to go with it.