1

Topic: [Resuelto] al cerrar la tapa → solo apagar la pantalla ← no funciona

Hola, quiero configurar mi hyperlaptop, para que al cerrar la tapa, no se suspenda, demora en volver a la normalidad, entonces encontré, la opcion en ajustes de energia, al cerrar la tapa, solo apagar la pantalla, y entonces elegí la opción, pero la opcion no funciona, entonces, hice un rgrep a la raiz, y encontré este archivo de configuraciòn y lo configuré así

/etc/elogind/logind.conf

#  This file is part of elogind.
#
#  elogind is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
#KillUserProcesses=yes
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
HandleLidSwitch=Switch off display
HandleLidSwitchDocked=Switch off display
#PowerKeyIgnoreInhibited=no
SuspendKeyIgnoreInhibited=no
HibernateKeyIgnoreInhibited=no
LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192
#UserTasksMax=33%

[Sleep]
#SuspendState=mem standby freeze
#SuspendMode=
#HibernateState=disk
#HibernateMode=platform shutdown
#HybridSleepState=disk
#HybridSleepMode=suspend platform shutdown

bueno y sigue sin funcionar, pero, de casualidad, ejecuté xfce4 con startx, y me doy cuenta que funciona, ya no suspende la laptop al cerrar la tapa. entonces, que opcion debo configurar para lograrlo, con el inicio de session con slim, ya que como comparto la laptop, es un poco fastidioso apagar el slim, salir de la session y arrancar el starx

esa es mi consulta,.
¿que debo de hacer para que funcione con el inicio de session con slim?
¿por qué funciona con el arranque de startx y con el administrador de session slim no?

y tambien con el rgrep encontré este archivo → /etc/lvm/lvm.conf ← y le puse esto

# Configuration option devices/ignore_suspended_devices.
# Ignore DM devices that have I/O suspended while scanning devices.
# Otherwise, LVM waits for a suspended device to become accessible.
# This should only be needed in recovery situations.
ignore_suspended_devices = 1

entonces no sé que falta

2

Re: [Resuelto] al cerrar la tapa → solo apagar la pantalla ← no funciona

Mi archivo /etc/elogind/logind.conf tiene todas las líneas comentadas. Cuando cierro la tapa de mi portátil, el rato no desaparece.

=-= Viva a Hyperbola ! Um chute na bunda do Systemd! =-=

3

Re: [Resuelto] al cerrar la tapa → solo apagar la pantalla ← no funciona

yikes, solo con descomentar la linea

HandleLidSwitch=ignore

poniendole ignore

haciendo un sudo service elogind restart

reiniciar la laptop, funcionó bién

4

Re: [Resuelto] al cerrar la tapa → solo apagar la pantalla ← no funciona

saravia wrote:

Hola, quiero configurar mi hyperlaptop, para que al cerrar la tapa, no se suspenda, demora en volver a la normalidad, entonces encontré, la opcion en ajustes de energia, al cerrar la tapa, solo apagar la pantalla, y entonces elegí la opción, pero la opcion no funciona, entonces, hice un rgrep a la raiz, y encontré este archivo de configuraciòn y lo configuré así

/etc/elogind/logind.conf

#  This file is part of elogind.
#
#  elogind is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
#KillUserProcesses=yes
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
HandleLidSwitch=Switch off display
HandleLidSwitchDocked=Switch off display
#PowerKeyIgnoreInhibited=no
SuspendKeyIgnoreInhibited=no
HibernateKeyIgnoreInhibited=no
LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192
#UserTasksMax=33%

[Sleep]
#SuspendState=mem standby freeze
#SuspendMode=
#HibernateState=disk
#HibernateMode=platform shutdown
#HybridSleepState=disk
#HybridSleepMode=suspend platform shutdown

bueno y sigue sin funcionar, pero, de casualidad, ejecuté xfce4 con startx, y me doy cuenta que funciona, ya no suspende la laptop al cerrar la tapa. entonces, que opcion debo configurar para lograrlo, con el inicio de session con slim, ya que como comparto la laptop, es un poco fastidioso apagar el slim, salir de la session y arrancar el starx

esa es mi consulta,.
¿que debo de hacer para que funcione con el inicio de session con slim?
¿por qué funciona con el arranque de startx y con el administrador de session slim no?

y tambien con el rgrep encontré este archivo → /etc/lvm/lvm.conf ← y le puse esto

# Configuration option devices/ignore_suspended_devices.
# Ignore DM devices that have I/O suspended while scanning devices.
# Otherwise, LVM waits for a suspended device to become accessible.
# This should only be needed in recovery situations.
ignore_suspended_devices = 1

entonces no sé que falta


Solo cambiar en /etc/elogind/logind.conf ;

...
HandleLidSwitch=Switch off display
...

por


...
HandleLidSwitch=ignore
...
~ Jesús E.
Hyperbola, Security Team