1

Topic: Couldn't past to login when stuck at “starting default runlevels”

Here's my first post I wrote in this thread.

Yesterday, I tried (re)installing base from scratch and migrating to version 0.3.x as testing on my old HP Pavilion laptop by getting right way of the instruction, then I rebooted it normally but stuck at “starting default runlevels” before login.

Can you please help me to solve this?

2 (edited by zapper 2019-07-15 14:56:15)

Re: Couldn't past to login when stuck at “starting default runlevels”

HarvettFox96 wrote:

Here's my first post I wrote in this thread.

Yesterday, I tried (re)installing base from scratch and migrating to version 0.3.x as testing on my old HP Pavilion laptop by getting right way of the instruction, then I rebooted it normally but stuck at “starting default runlevels” before login.

Can you please help me to solve this?

Welcome!

I have had an issue with something similar before.  Unless you are beta testing, its usually better to use Stable.  But if you would like I can ask Emulatorman how to rectify that otherwise.  smile

He is a kind soul who I am sure can help you revert. smile

If not, I will try to help you. 

You need two things though, a live 2.9 hyperbola iso.  and I need to know if you encrypted your disks.  If you tell me that I can help you chroot into your install and  revert to stable.  smile

but please *do not* tell me your *password*

here especially... or anywhere for that matter...

Hyperbola:

The Stable Secure Libre Arch!

3

Re: Couldn't past to login when stuck at “starting default runlevels”

HarvettFox96 wrote:

Here's my first post I wrote in this thread.

Yesterday, I tried (re)installing base from scratch and migrating to version 0.3.x as testing on my old HP Pavilion laptop by getting right way of the instruction, then I rebooted it normally but stuck at “starting default runlevels” before login.

Can you please help me to solve this?

Currently, Milky Way v0.3 is suggested only for beta-test users since it isn't stabilized yet. If you have plans to debug it, please let us know and send us logs or info from gdb by including the backtrace about those applications which contains issues, however if you have plans to use it as system for normal using, i suggest you install Milky Way v0.2, not v0.3.

4 (edited by HarvettFox96 2019-07-18 07:50:47)

Re: Couldn't past to login when stuck at “starting default runlevels”

Sorry about that I was a bit dumb. Now here's the solution I made, you need to add some exact other services manually to work via arch-chroot on live image, like this:

# export PATH="$PATH:/bin/:/sbin/:/usr/sbin/"
# arch-chroot /mnt/
# rc-update add agetty.tty1 default nonetwork
...
# rc-update add agetty.tty12 default nonetwork
# rc-update add dhcpcd default
# rc-update add dmesg boot
# rc-update add hwclock boot
# rc-update add keymaps boot
# rc-update add killprocs shutdown
# rc-update add loopback boot
# rc-update add modules boot
# rc-update add mount-ro shutdown
# rc-update add net.lo boot
# rc-update add swap boot
# rc-update add udev-trigger

Edit 1: Forgot to add udev-trigger service.

5 (edited by zapper 2019-07-18 01:32:11)

Re: Couldn't past to login when stuck at “starting default runlevels”

HarvettFox96 wrote:

Sorry about that I was a bit dumb. Now here's the solution I made, you need to add some exact other services manually via arch-chroot on live image, like this:

# arch-chroot /mnt
# rc-update add agetty.tty1 default nonetwork
...
# rc-update add agetty.tty12 default nonetwork
# rc-update add dhcpcd default
# rc-update add dmesg boot
# rc-update add hwclock boot
# rc-update add keymaps boot
# rc-update add killprocs shutdown
# rc-update add loopback boot
# rc-update add modules boot
# rc-update add mount-ro shutdown
# rc-update add net.lo boot
# rc-update add swap boot

So is your problem solved?  just be careful when you think moving to a beta install is smart. smile well, without any idea how to fix it, etc...

It is okay to move to beta if you know what you are doing, but otherwise, not recommended. tongue

Hyperbola:

The Stable Secure Libre Arch!

6

Re: Couldn't past to login when stuck at “starting default runlevels”

runlevels for default

$ rc-status --all
Runlevel: nonetwork
 agetty.tty9                          [  started 00:25:49 (0) ]
 agetty.tty8                          [  started 00:25:49 (0) ]
 agetty.tty7                          [  started 00:25:49 (0) ]
 agetty.tty6                          [  started 00:25:49 (0) ]
 agetty.tty5                          [  started 00:25:49 (0) ]
 agetty.tty4                          [  started 00:25:48 (0) ]
 agetty.tty3                          [  started 00:25:48 (0) ]
 agetty.tty2                          [  started 00:25:48 (0) ]
 agetty.tty12                         [  started 00:25:48 (0) ]
 agetty.tty11                         [  started 00:25:48 (0) ]
 agetty.tty10                         [  started 00:25:48 (0) ]
 agetty.tty1                          [  started 00:25:48 (0) ]
Runlevel: default
 NetworkManager                                   [  started  ]
 acpid                                            [  started  ]
 alsasound                                        [  started  ]
 agetty.tty9                          [  started 00:25:49 (0) ]
 agetty.tty8                          [  started 00:25:49 (0) ]
 agetty.tty7                          [  started 00:25:49 (0) ]
 agetty.tty6                          [  started 00:25:49 (0) ]
 agetty.tty5                          [  started 00:25:49 (0) ]
 agetty.tty4                          [  started 00:25:48 (0) ]
 agetty.tty3                          [  started 00:25:48 (0) ]
 agetty.tty2                          [  started 00:25:48 (0) ]
 agetty.tty12                         [  started 00:25:48 (0) ]
 agetty.tty11                         [  started 00:25:48 (0) ]
 agetty.tty10                         [  started 00:25:48 (0) ]
 agetty.tty1                          [  started 00:25:48 (0) ]
Runlevel: boot
 dmesg                                            [  started  ]
 hwclock                                          [  started  ]
 modules                                          [  started  ]
 root                                             [  started  ]
 swap                                             [  started  ]
 hostname                                         [  started  ]
 sysctl                                           [  started  ]
 bootmisc                                         [  started  ]
 net.lo                                           [  started  ]
 keymaps                                          [  started  ]
 loopback                                         [  started  ]
 urandom                                          [  started  ]
Runlevel: shutdown
 killprocs                                        [  stopped  ]
 mount-ro                                         [  stopped  ]
Runlevel: sysinit
 udev-trigger                                     [  started  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 devfs                                            [  started  ]
 sysfs                                            [  started  ]
 udev                                             [  started  ]
 fsck                                             [  started  ]
 localmount                                       [  started  ]
 elogind                                          [  started  ]
 dbus                                             [  started  ]
 termencoding                                     [  started  ]
Dynamic Runlevel: manual
~ Jesús E.
Hyperbola, Security Team