Topic: PGP Signature Error Installing Package

I am new to Hyperbola and recently installed it on my PC currently using the XFCE desktop.  I have experimented with a handful of the Libre GNU/Linux system distributions out there, and just made the switch to Hyperbola because I like the projects seriousness about software freedom.  I am not a developer, but I want to run a truly free system on my PCs.  Despite the time I have spent installing GNU/Linux on my machines, I am still on the learning curve and have the following new problem I am trying to work through:

I have started to experiment with my installation and wanted to add gvfs which I did and it appeared to work for the most part (for automounting of usb disk drives).  For some reason, I later removed the gvfs package, then I tried to reinstall it but now I get a problem with the PGP signature when it check the keys.

error: gvfs: signature from "André Silva <emulatorman@hyperbola.info>" is unknown trust
:: File /var/cache/pacman/pkg/gvfs-1.32.1-1.hyperbola9-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

I have tried resetting the keys using the procedure in the wiki, but it does not remove the problem.  I do not fully understand the keys and why they worked at one time but fail to work now on the same package.  Any ideas on this?  Should I just try to reinstall the whole system?

By the way, I had a similar error when first installing the system from a USB stick.  At that time I had to reset the keys (as described in the Hyperbola install wiki) but only after chrooting during the initial install.  I am guessing that is a normal part of the installation procedure.


Re: PGP Signature Error Installing Package

Yes, that worked.  Thanks.