1

Topic: Support for development of packages and applications in Hyperbola 0.4

Hello all,

within this thread you can share your notes and help for the creation of PKGBUILD-scripts needed for all the applications and packages to be included in Hyperbola GNU/Linux-libre 0.4 as next major release of our project. Please have a look therefore at the following git-repository: https://git.hyperbola.info:50100/~team/ … /todo.git/

The following files are relevant:

packages.md containing all packages being ready, needing more research or already worked onto
packages_not-included.md containing packages being removed for now or just impossible to be further included
packages_added-later.md containing possible candidates to be added within Hyperbola after release 0.4

You have questions or any kind of comment? Please feel free and share it here.
You can choose many forms sharing and also use just the forum for patches and PKGBUILD-proposals.
But please only those applications / packages being part of the list packages.md and of course also the dependencies included! We have not the time to include more applications for now.

Some rules for the time being:

You want to work onto some application / packages and needed dependencies? Just a comment here and we add your name onto the list.
You have a PKGBUILD ready being added? Add a link for the files for doing a first review, or just as code-segment here in the forum. Please test your build at best for both 64bit and 32bit!

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

2

Re: Support for development of packages and applications in Hyperbola 0.4

Adding later:

scummvm
pencil2d

Also look onto tor-lts and i2pd.

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

3

Re: Support for development of packages and applications in Hyperbola 0.4

Adding direct links to packages.md and packages_not-included.md to this topic wink

"This life is short Eternity is long, who want good trees plant good seeds."

"quote" taken from sam garrens an english writer and speaker,
Were do you think we live!

4

Re: Support for development of packages and applications in Hyperbola 0.4

rachad wrote:

Adding direct links to packages.md and packages_not-included.md to this topic wink

Thanks, added the links in the initial posting! big_smile

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

5

Re: Support for development of packages and applications in Hyperbola 0.4

Perfect! I am missing only these:
xtrlock
abook
getmail
radis-font
cadaver
calcurse
urxvt-perls

6

Re: Support for development of packages and applications in Hyperbola 0.4

gnu wrote:

Perfect! I am missing only these:
xtrlock
abook
getmail
radis-font
cadaver
calcurse
urxvt-perls

Let me check the next commit:

xtrlock
getmail6 (not getmail)
cadaver
calcurse

That's the packages to come today also. smile
Just testing scummvm now with some games to run within.

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

7

Re: Support for development of packages and applications in Hyperbola 0.4

Since that thread seems to be locked, now I have four more upcoming packages.

8

Re: Support for development of packages and applications in Hyperbola 0.4

HarvettFox96 wrote:

Since that thread seems to be locked, now I have four more upcoming packages.

Thank you HarvettFox96 they were add https://git.hyperbola.info:50100/~team/ … /?h=rachad

"This life is short Eternity is long, who want good trees plant good seeds."

"quote" taken from sam garrens an english writer and speaker,
Were do you think we live!

9

Re: Support for development of packages and applications in Hyperbola 0.4

Help needed for the package dolphin-emu as this is ONLY available for x86_64: I have no environment for now available to create the PKGBUILD. If nobody is interested this is one package to be done later, otherwise it would be cool for someone to have a look into that. The problem itself: i686 is not possible for this application.

So there are two options: Doing the same as with 0.3.1 now, release this one only for 64bit or remove the package and emulator completely for 0.4 and later. So this question includes not only a call for help as also some kind of decision: Include dolphin-emu or remove it?

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

10

Re: Support for development of packages and applications in Hyperbola 0.4

gnu wrote:

Perfect! I am missing only these:
xtrlock
abook
getmail
radis-font
cadaver
calcurse
urxvt-perls

Sorry but radis-font is not possible to add until you specify more details where to find the source-code for this package. Is it radisnoir?

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

11

Re: Support for development of packages and applications in Hyperbola 0.4

Sorry ^_^
https://packages.debian.org/buster/fonts-radisnoir
http://www.radisnoir.net/

12

Re: Support for development of packages and applications in Hyperbola 0.4

List was updated. Thanks: radisnoir-font added as package also.

https://git.hyperbola.info:50100/~team/ … ackages.md

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

13

Re: Support for development of packages and applications in Hyperbola 0.4

Building QtFM without D-bus works, but otherwise, with media thumbnail support, it fails because QtFM requires ImageMagick for dependency.

Another two more upcoming packages arrived here.

14

Re: Support for development of packages and applications in Hyperbola 0.4

HarvettFox96 wrote:

Building QtFM without D-bus works, but otherwise, with media thumbnail support, it fails because QtFM requires ImageMagick for dependency.

Another two more upcoming packages arrived here.

its Done HarvettFox96 wink
https://git.hyperbola.info:50100/~team/ … 027b3e9530
https://git.hyperbola.info:50100/~team/ … f374909d90

"This life is short Eternity is long, who want good trees plant good seeds."

"quote" taken from sam garrens an english writer and speaker,
Were do you think we live!

15

Re: Support for development of packages and applications in Hyperbola 0.4

HarvettFox96, next time use the source tarball provided by the pkg developers and only patches from debian sources.

"This life is short Eternity is long, who want good trees plant good seeds."

"quote" taken from sam garrens an english writer and speaker,
Were do you think we live!

16

Re: Support for development of packages and applications in Hyperbola 0.4

Help is needed for VLC and LibreOffice: Would be cool to get most dependencies into the repositories so we can start building those big applications. Thanks! smile

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

17

Re: Support for development of packages and applications in Hyperbola 0.4

Help is needed for building samba: The current build fails with errors about manpages-configuration. Version is 4.13.5!
Hints welcomed to get further:

https://bugs.gentoo.org/488168
https://bugzilla.samba.org/show_bug.cgi?id=9515

Found the error: docbook-xsl will get an update as the patchset was not completely done. wink

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

18

Re: Support for development of packages and applications in Hyperbola 0.4

figlet                         --> http://www.figlet.org/
mailutils                     --> https://mailutils.org/
trash-cli                      --> https://github.com/andreafrancia/trash-cli
odt2txt                       --> https://github.com/dstosberg/odt2txt/
libimage-exiftool-perl --> https://exiftool.org/
unclutter                    --> https://web.archive.org/web/20151129214 … utilities/
poppler-utils               --> https://poppler.freedesktop.org/
abook                         --> https://abook.sourceforge.io/
ftp                              --> https://directory.fsf.org/wiki/Netkit-ftp
wavemon                   --> https://github.com/uoaerg/wavemon/

##### #    #   ##   #    # #    #  ####  
  #   #    #  #  #  ##   # #   #  #      
  #   ###### #    # # #  # ####    ####  
  #   #    # ###### #  # # #  #        # 
  #   #    # #    # #   ## #   #  #    # 
  #   #    # #    # #    # #    #  ####  
 _   _                 _        
| | | |               | |       
| |_| |__   __ _ _ __ | | _____ 
| __| '_ \ / _` | '_ \| |/ / __|
| |_| | | | (_| | | | |   <\__ \
 \__|_| |_|\__,_|_| |_|_|\_\___/

19 (edited by gnu 2021-07-27 19:44:36)

Re: Support for development of packages and applications in Hyperbola 0.4

...

20 (edited by HarvettFox96 2021-07-29 12:56:51)

Re: Support for development of packages and applications in Hyperbola 0.4

Another two more upcoming packages arrived here. And unfortunately, LibreGit had its SSL cert expired while I'm providing those alternative links.

At least bmpanel2 works but Qt can't handle strings displaying into other taskbar items on some WMs.

rachad wrote:

HarvettFox96, next time use the source tarball provided by the pkg developers and only patches from debian sources.

I understand you, rachad. Somewhat on Debian, they noticed cool-retro-term that it contains qmltermwidget in its source archive.

21

Re: Support for development of packages and applications in Hyperbola 0.4

Thanks for adding, but are those packages for 0.4 or can be added later?
And qmltermwidget is not possible to be compiled under i686 for now on the build-server. So we need doing a research what is going wrong here, doing that later with librechroot-environment on i686-system.

For all participants: Please do not add packages being able to be added later in another release like 0.4.1. Therefore you can use this thread. We need to complete the concurrent TODO-list as marked in the initial posting and it would be helpful even more for us to get help with the packages listed there. Here again the link: packages.md

At best some proposals:

varnish (OpenRC and runit included)
lighttpd (OpenRC and runit included)
syncthing (OpenRC and runit included)
gajim
php
wicd (research included)
davical (OpenRC and runit included)
radicale (OpenRC and runit included)
opensmtpd (OpenRC and runit included)
postfix (OpenRC and runit included)
dovecot (OpenRC and runit included)
urxvt-perls
virt-manager (research included)
vim (research included, please also speak to Emulatorman)
qtractor
muse
hydrogen
gigamesh
toonloop
lives
pitivi (for the interested as there is bunch of research)
papagayo

There are also some window-managers:

awesomewm
vtwm
stumpwm

And as hard as this sounds: Neither lwm nor bmpanel2 were added once to the list as it was initial created. There was enough time to add them. For sure we'll try to add what we can, so this is not about being disrespecting all wishes from the community. But please again: Have an understanding as ALL packages added needs also testing and working in combination with others installed. This is not as easy as it sounds and using your own environment for building is a good first step to learn, but looking at the complete picture with all possible scenarios is just another, complete different story. wink It is fine if some here think Hyperbola GNU/Linux-libre 0.4 is now ready, but that's your point of view. Others have a different point and our TODO-list is not done yet. There can be also packages being not addressed any further as for example syncthing has its problems with go and compilation right now. So even if your build works under one system-architecture, there is no guarantee it is working on others and most time we try to use all. Meaning 32bit AND 64bit for example! Hyperbola is also addressing both: Desktop and Server, so we need services being stable to run with all INIT-systems we are supporting. Not a problem when some don't work right now under runit or OpenRC. But again here: That needs fixing within the next step to come. So the steps are clear:

- Finalize the TODO-list
- Go into BETA-state and test what we can

No time for extra packages, when they need even more time!
Generic to add from the experiences of the past two months, not meant to anyone here in the thread: And also no time when people ignore the focus of Hyperbola itself especially as we won't be able to use those PKGBUILD-scripts then when they're missing ground dependencies.

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

22

Re: Support for development of packages and applications in Hyperbola 0.4

HarvettFox96 wrote:

Another two more upcoming packages arrived here. And unfortunately, LibreGit had its SSL cert expired while I'm providing those alternative links.

At least bmpanel2 works but Qt can't handle strings displaying into other taskbar items on some WMs.

rachad wrote:

HarvettFox96, next time use the source tarball provided by the pkg developers and only patches from debian sources.

I understand you, rachad. Somewhat on Debian, they noticed cool-retro-term that it contains qmltermwidget in its source archive.

Added the corresponding packages. Package lwm needed a short rework: Please try to move the debian-folder and not just copy it whenever possible.

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

23

Re: Support for development of packages and applications in Hyperbola 0.4

I thought of one other package of use...

It is for cloning from one drive to another:

such as /dev/sda to one other usb drive, etc...
clonezilla...

fsf has its own page of it,

https://directory.fsf.org/wiki/Clonezilla

is one example:

https://packages.debian.org/buster/clonezilla

It can be installed, but I can't get it working without FHS adaptions,

HyperbolaBSD: The Future of Secure Libre Lightweight Operating Systems!

24

Re: Support for development of packages and applications in Hyperbola 0.4

zapper wrote:

I thought of one other package of use...

It is for cloning from one drive to another:

such as /dev/sda to one other usb drive, etc...
clonezilla...

fsf has its own page of it,

https://directory.fsf.org/wiki/Clonezilla

is one example:

https://packages.debian.org/buster/clonezilla

It can be installed, but I can't get it working without FHS adaptions,

Won't be possible for now and can be a candidate for later integration. But just to mention: The package on "Arch Linux" has also dependencies towards systemd, which needs research and removal. So definitely not possible now with 0.4 but later releases.

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!

25

Re: Support for development of packages and applications in Hyperbola 0.4

Here you have it: