1

Topic: Duda sobre OpenRC

Hola muchach@s

Les cuento que soy usuario de Parabola GNU/Linux-libre desde hace unos años. Al realizar la instalación de Parabola con OpenRC, pero al finalizar la distribución del teclado no cambia.

En /etc/conf.d/keymaps he colocado "la-latin1"

Los comandos que usado para la instalación han sido los siguientes:

loadkeys la-latin1
cfdisk 

      sda1 --> /   
      sda2 --> /home 
      sda3 --> swap
     
                                           
mkfs.ext4 /dev/sda1
mkfs.ext4 /dev/sda2
mkswap /dev/sda3
mount /dev/sda1 /mnt
mkdir /mnt/home
mount /dev/sda2/ mnt/home
swapon /dev/sda3

rc-update add dhcpcd default

pacman -Sy parabola-keyring
pacman -Sy archlinux-keyring
pacman-key --populate parabola
pacman-key --populate archlinux
pacman-key --refresh-keys
pacman -Sy archlinux-keyring
pacman -Sy parabola-keyring

pacstrap /mnt base-openrc
pacstrap /mnt grub-bios

rc-update add cronie default
rc-update add dbus default

genfstab -p /mnt >> /mnt/etc/fstab
arch-chroot /mnt

nano /etc/conf.d/hostname
    Reemplace localhost con j2rm

nano /etc/locale.conf
    LANG="es_VE.UTF-8"
    export LANG=es_VE.UTF-8

nano /etc/locale.gen
    borrae el # delante de es_VE.UTF-8

nano /etc/conf.d/keymaps
    keymap="la-latin1"

rc-service keymaps restart

locale-gen
ln -sf /usr/share/zoneinfo/America/Caracas /etc/localtime

mkinitcpio -p linux-libre
    
grub-install /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg


passwd
    CLAVE
    CLAVE

exit

nano /etc/NetworkManager/NetworkManager.conf
    Añadi
# Static hostname
[keyfile]
hostname=j2rm

umount -a
reboot

root
    CLAVE

pacman -S openrc-desktop

pacman -S polkit-elogind
rc-update add elogind default

pacman -S eudev-systemd libeudev-systemd

rc-update add lvm boot
rc-update add dmcrypt boot
rc-update add dbus default
rc-update add alsasound default
rc-update add cronie default
rc-update add dhcpcd default
rc-update add NetworkManager default

useradd -m -g users -G "adm,audio,lp,optical,storage,video,wheel,games,power,scanner" j2rm

passwd j2rm
    CLAVE
    CLAVE

exit
j2rm
    CLAVE
su
    CLAVE

pacman -S networkmanager-elogind

pacman -S xorg-server xorg-xinit xf86-video-vesa xf86-input-evdev pulseaudio pulseaudio-alsa 
          notify-osd pavucontrol
                                   
pacman -S xfce4 xfc4-goodies gamin

pacman -S xdg-user-dirs qtox audacious gimp xournal mplayer iceweasel iceweasel-l10n-es-es
          pdftk mupdf mps-youtube youtube-dl libreoffice-fresh libreoffice-fresh-es icedove
          icedove-l10n-es-es unar xarchiver gvfs unzip aspell-es ttf-droid ttf-liberation
          ttf-inconsolata artwiz-fonts ttf-bitstream-vera ttf-freefont ttf-dejavu irssi 
          wget steadyflow imagemagick

nano /etc/X11/xinit/.xinitrc 
    exec startxfce4 --with-ck-launch 
                                    
nano /etc/X11/Xwrapper.config   
# Xorg.wrap configuation file 
needs_root_rights = no

touch /etc/sysctl.conf
mkdir /usr/lib/rc/cache

reboot

De antemano muchas gracias por su tiempo.

Abrazos!!

2

Re: Duda sobre OpenRC

j2rm wrote:

Hola muchach@s

Les cuento que soy usuario de Parabola GNU/Linux-libre desde hace unos años. Al realizar la instalación de Parabola con OpenRC, pero al finalizar la distribución del teclado no cambia.

En /etc/conf.d/keymaps he colocado "la-latin1"

Los comandos que usado para la instalación han sido los siguientes:

loadkeys la-latin1
cfdisk 

      sda1 --> /   
      sda2 --> /home 
      sda3 --> swap
     
                                           
mkfs.ext4 /dev/sda1
mkfs.ext4 /dev/sda2
mkswap /dev/sda3
mount /dev/sda1 /mnt
mkdir /mnt/home
mount /dev/sda2/ mnt/home
swapon /dev/sda3

rc-update add dhcpcd default

pacman -Sy parabola-keyring
pacman -Sy archlinux-keyring
pacman-key --populate parabola
pacman-key --populate archlinux
pacman-key --refresh-keys
pacman -Sy archlinux-keyring
pacman -Sy parabola-keyring

pacstrap /mnt base-openrc
pacstrap /mnt grub-bios

rc-update add cronie default
rc-update add dbus default

genfstab -p /mnt >> /mnt/etc/fstab
arch-chroot /mnt

nano /etc/conf.d/hostname
    Reemplace localhost con j2rm

nano /etc/locale.conf
    LANG="es_VE.UTF-8"
    export LANG=es_VE.UTF-8

nano /etc/locale.gen
    borrae el # delante de es_VE.UTF-8

nano /etc/conf.d/keymaps
    keymap="la-latin1"

rc-service keymaps restart

locale-gen
ln -sf /usr/share/zoneinfo/America/Caracas /etc/localtime

mkinitcpio -p linux-libre
    
grub-install /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg


passwd
    CLAVE
    CLAVE

exit

nano /etc/NetworkManager/NetworkManager.conf
    Añadi
# Static hostname
[keyfile]
hostname=j2rm

umount -a
reboot

root
    CLAVE

pacman -S openrc-desktop

pacman -S polkit-elogind
rc-update add elogind default

pacman -S eudev-systemd libeudev-systemd

rc-update add lvm boot
rc-update add dmcrypt boot
rc-update add dbus default
rc-update add alsasound default
rc-update add cronie default
rc-update add dhcpcd default
rc-update add NetworkManager default

useradd -m -g users -G "adm,audio,lp,optical,storage,video,wheel,games,power,scanner" j2rm

passwd j2rm
    CLAVE
    CLAVE

exit
j2rm
    CLAVE
su
    CLAVE

pacman -S networkmanager-elogind

pacman -S xorg-server xorg-xinit xf86-video-vesa xf86-input-evdev pulseaudio pulseaudio-alsa 
          notify-osd pavucontrol
                                   
pacman -S xfce4 xfc4-goodies gamin

pacman -S xdg-user-dirs qtox audacious gimp xournal mplayer iceweasel iceweasel-l10n-es-es
          pdftk mupdf mps-youtube youtube-dl libreoffice-fresh libreoffice-fresh-es icedove
          icedove-l10n-es-es unar xarchiver gvfs unzip aspell-es ttf-droid ttf-liberation
          ttf-inconsolata artwiz-fonts ttf-bitstream-vera ttf-freefont ttf-dejavu irssi 
          wget steadyflow imagemagick

nano /etc/X11/xinit/.xinitrc 
    exec startxfce4 --with-ck-launch 
                                    
nano /etc/X11/Xwrapper.config   
# Xorg.wrap configuation file 
needs_root_rights = no

touch /etc/sysctl.conf
mkdir /usr/lib/rc/cache

reboot

De antemano muchas gracias por su tiempo.

Abrazos!!

Hola j2rm.

Es genial que uses una distro 100 % Libre; este es el foro de soporte para Hyperbola GNU+Linux-libre/Hurd. Sin embargo veo que el problema posiblemente proviene de la configuración de la distribución de teclado desde Xorg.

Solución (si Xorg es el problema):

Editas ó creas (con nano o con cualquier editor de texto plano): /etc/X11/xorg.conf.d/00-keyboard.conf

Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "es"
    Option "XkbModel" "pc105"
EndSection

El asunto es que SystemD agregaba esas configuraciones, y claro SystemD solo debería ser un init.

~ Jesús E.
Hyperbola, Security Team

3

Re: Duda sobre OpenRC

Heckyel wrote:
j2rm wrote:

Hola muchach@s

Les cuento que soy usuario de Parabola GNU/Linux-libre desde hace unos años. Al realizar la instalación de Parabola con OpenRC, pero al finalizar la distribución del teclado no cambia.

En /etc/conf.d/keymaps he colocado "la-latin1"

Los comandos que usado para la instalación han sido los siguientes:

loadkeys la-latin1
cfdisk 

      sda1 --> /   
      sda2 --> /home 
      sda3 --> swap
     
                                           
mkfs.ext4 /dev/sda1
mkfs.ext4 /dev/sda2
mkswap /dev/sda3
mount /dev/sda1 /mnt
mkdir /mnt/home
mount /dev/sda2/ mnt/home
swapon /dev/sda3

rc-update add dhcpcd default

pacman -Sy parabola-keyring
pacman -Sy archlinux-keyring
pacman-key --populate parabola
pacman-key --populate archlinux
pacman-key --refresh-keys
pacman -Sy archlinux-keyring
pacman -Sy parabola-keyring

pacstrap /mnt base-openrc
pacstrap /mnt grub-bios

rc-update add cronie default
rc-update add dbus default

genfstab -p /mnt >> /mnt/etc/fstab
arch-chroot /mnt

nano /etc/conf.d/hostname
    Reemplace localhost con j2rm

nano /etc/locale.conf
    LANG="es_VE.UTF-8"
    export LANG=es_VE.UTF-8

nano /etc/locale.gen
    borrae el # delante de es_VE.UTF-8

nano /etc/conf.d/keymaps
    keymap="la-latin1"

rc-service keymaps restart

locale-gen
ln -sf /usr/share/zoneinfo/America/Caracas /etc/localtime

mkinitcpio -p linux-libre
    
grub-install /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg


passwd
    CLAVE
    CLAVE

exit

nano /etc/NetworkManager/NetworkManager.conf
    Añadi
# Static hostname
[keyfile]
hostname=j2rm

umount -a
reboot

root
    CLAVE

pacman -S openrc-desktop

pacman -S polkit-elogind
rc-update add elogind default

pacman -S eudev-systemd libeudev-systemd

rc-update add lvm boot
rc-update add dmcrypt boot
rc-update add dbus default
rc-update add alsasound default
rc-update add cronie default
rc-update add dhcpcd default
rc-update add NetworkManager default

useradd -m -g users -G "adm,audio,lp,optical,storage,video,wheel,games,power,scanner" j2rm

passwd j2rm
    CLAVE
    CLAVE

exit
j2rm
    CLAVE
su
    CLAVE

pacman -S networkmanager-elogind

pacman -S xorg-server xorg-xinit xf86-video-vesa xf86-input-evdev pulseaudio pulseaudio-alsa 
          notify-osd pavucontrol
                                   
pacman -S xfce4 xfc4-goodies gamin

pacman -S xdg-user-dirs qtox audacious gimp xournal mplayer iceweasel iceweasel-l10n-es-es
          pdftk mupdf mps-youtube youtube-dl libreoffice-fresh libreoffice-fresh-es icedove
          icedove-l10n-es-es unar xarchiver gvfs unzip aspell-es ttf-droid ttf-liberation
          ttf-inconsolata artwiz-fonts ttf-bitstream-vera ttf-freefont ttf-dejavu irssi 
          wget steadyflow imagemagick

nano /etc/X11/xinit/.xinitrc 
    exec startxfce4 --with-ck-launch 
                                    
nano /etc/X11/Xwrapper.config   
# Xorg.wrap configuation file 
needs_root_rights = no

touch /etc/sysctl.conf
mkdir /usr/lib/rc/cache

reboot

De antemano muchas gracias por su tiempo.

Abrazos!!

Hola j2rm.

Es genial que uses una distro 100 % Libre; este es el foro de soporte para Hyperbola GNU+Linux-libre/Hurd. Sin embargo veo que el problema posiblemente proviene de la configuración de la distribución de teclado desde Xorg.

Solución (si Xorg es el problema):

Editas ó creas (con nano o con cualquier editor de texto plano): /etc/X11/xorg.conf.d/00-keyboard.conf

Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "es"
    Option "XkbModel" "pc105"
EndSection

El asunto es que SystemD agregaba esas configuraciones, y claro SystemD solo debería ser un init.


Hola amigo Heckyel!!!

Oye mucha gracias por tu ayuda, gracias a ella el problema esta resuelto.