1

Topic: After upgrade, no sound

All I have done was sudo pacman -Syuu --confirm and after reboot I cannot find any sound any more. I can hear beeps which I did not hear before.

No mixer is working, pulseaudio is I think not there.

Please help me. The upgrade shall not remove sound.

What do I have to do now to enable sound?

2 (edited by zapper 2019-10-07 20:55:45)

Re: After upgrade, no sound

Strange, I don't have that problem. Are you on Testing or Stable?

Tell me, have you done,

sudo rc-service alsasound start?

or, sudo rc-service pulseaudio start?

or, rc-update add pulseaudio default?

or, rc-update add alsasound default?

I guess I am wondering, what you have tried to do to fix the issue. 

You need alsa-lib and alsa-utils to make alsa work though. just a heads up.

Hyperbola:

The Stable Secure Libre Arch!

3

Re: After upgrade, no sound

I think sound is not recognized by new kernel. I am trying to downgrade:

09:04 <jmarciano> instructions on
                  https://wiki.hyperbola.info/doku.php?id=en:main:sources
                  are not sufficient, as after sudo libremakepkg,
                  there is: ==> ERROR: PKGBUILD does not exist.
09:13 *** kerframil QUIT Quit: Leaving
09:30 <jmarciano> I think I am here:
                  https://git.hyperbola.info:50100/packag … c3b990ae59
09:30 <jmarciano> but how do I get raw file: PKGBUILD?
09:31 <jmarciano> I think I got it here:
                  https://git.hyperbola.info:50100/packag … c3b990ae59
09:32 <jmarciano> trying to use that PKGBUILD now to downgrade the
                  kernel, so that Intel HDA Audio starts working
                  expectedly.
09:33 <jmarciano> ==> Downloading sources...
09:33 <jmarciano>  |  ==> FEHLER: install-Datei (linux.install)
                  existiert nicht oder ist keine reguläre Datei.
09:33 <jmarciano> that is error, file linux.install does not exist
09:33 <jmarciano> where do I find linux.install?
09:35 <jmarciano> if somebody knows the answer to it, please let me know

If I find linux.install file in Git, I can maybe downgrade to kernel version that worked. Anybody knows how to get linux.install file?

4 (edited by throgh 2019-10-08 11:07:09)

Re: After upgrade, no sound

Hava a look here: https://git.hyperbola.info:50100/packag … -libre-lts
And you need really all files, otherwise the command "makepkg" cannot start with building.

5 (edited by jmarciano 2019-10-08 13:20:44)

Re: After upgrade, no sound

Thank you, very nice of you, I found the files and I have used the commit number here:
https://git.hyperbola.info:50100/packag … c3b990ae59

Do you know how do I use libremakepkg with the option
--skippgpcheck

as one of signatures cannot be verified for some reason. I am trying now with makepkg, but for libremakepkg I cannot see how can I use that option.

Kernel is being built, I hope to get sound working again.

6

Re: After upgrade, no sound

I have solved it, but not that I think it is connected to kernel version. Some Intel cards require program hdajackretask, and it creates (somehow) /lib/firmware/hda-jack-retask.fw and such did not exist after upgrade. It can be that FHS upgrade removed that file, but it should not in my opinion remove anything from system that is not confirmed by the administrator.

But it can also be that Hyperbola removed some files from /etc/modprobe.d/ so I cannot know why I lost sound. But it is not due to kernel, rather due to hdajackretask and missing firmware after upgrade.

I fiddled with hdajackretask and I got it working, I do not know how, don't ask. I just installed it, it created firmware and /etc/modprobe.d/hda-jack-retask.conf and later by fiddling with pavucontrol-qt I could get it to work.

So thread is now closed.

Content of the file:

cat /etc/modprobe.d/hda-jack-retask.conf
# This file was added by the program 'hda-jack-retask'.
# If you want to revert the changes made by this program, you can simply erase this file and reboot your computer.
options snd-hda-intel patch=hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw,hda-jack-retask.fw