1 (edited by freemedia 2018-11-11 21:35:41)

Topic: destroyed another laptop speaker today

yeah, thats how i mute them now. before you laugh, realise im already in the habit of physically removing the mic and the speakers could technically be used as a microphone. as i said though, this was just to make certain they dont start blaring sound in the middle of the night.

ive always found that uninstalling pulseaudio makes life better. unfortunately, lozilla and icecat insist on it (if you want audio.)

does iceweasel uxp require it? if not, perhaps i will switch and ditch pa again.

pa helpfully turns the speakers all the way up every time i unplug my headphones.

yeah, even if i turn the speakers all the way down, it just wants them up to 100 every time i unplug my headphones.

i went looking for a way to turn this garbage off, as usual, its easier to configure a u.s. navy submarine: https://unix.stackexchange.com/question … pulseaudio

they never did find the way to do it. i want to disable the speakers, not the headphones. ideally, just to disable the automute.

or, to just use a web browser without pa. because alsa works fine without it, only the browser doesnt.

2

Re: destroyed another laptop speaker today

freemedia wrote:

yeah, thats how i mute them now. before you laugh, realise im already in the habit of physically removing the mic and the speakers could technically be used as a microphone. as i said though, this was just to make certain they dont start blaring sound in the middle of the night.

ive always found that uninstalling pulseaudio makes life better. unfortunately, lozilla and icecat insist on it (if you want audio.)

does iceweasel uxp require it? if not, perhaps i will switch and ditch pa again.

pa helpfully turns the speakers all the way up every time i unplug my headphones.

yeah, even if i turn the speakers all the way down, it just wants them up to 100 every time i unplug my headphones.

i went looking for a way to turn this garbage off, as usual, its easier to configure a u.s. navy submarine: https://unix.stackexchange.com/question … pulseaudio

they never did find the way to do it. i want to disable the speakers, not the headphones. ideally, just to disable the automute.

or, to just use a web browser without pa. because alsa works fine without it, only the browser doesnt.

I don't think it would be a problem, but you should look at iceweasel-uxp's dependencies first.  also, I never had that problem with pulseaudio. I can easily disable speakers and not headphones.  Along with mic and everything else.

I wonder why it doesn't work like that for you though...

Is your device a libreboot device? I know from experience I have no problem with my x200 doing this...

Although... my kororapenguin a thinkpenguin laptop has had the problem you described... hmmm...

Hyperbola:

The Stable Secure Libre Arch!

3 (edited by freemedia 2018-11-12 00:54:03)

Re: destroyed another laptop speaker today

i dont think this is a firmware issue, i think it is a configuration issue.

you could be right though-- alsa could operate differently with some firmware vs pa.

although the link that i posted in frustration was pretty useless to me, i did find another thread that recommended something in the first link (i think so-- this is still absurdly overcomplicated. remember when features like this were off by default or easier to find and fix? i dont mean in 1998, i mean in 2008, 2009, 2010, 2011, 2012... really until up to 4 years ago.)

one of the solutions that came up twice, i gave it a try and its the one i will be trying in the future before i start dismantling hardware.

maybe im silly for thinking that pa should respect the setting that the user sets with alsamixer. though i think pa should respect the setting that the user sets with alsamixer-- as usual. daddy lennart always knows best. i can forgive the 4 years of forcing the gnu/linux ecosystem to reassert itself, but hes really just bent on breaking everything he touches, isnt he?

well, here-- should someone have the same problem, they can try this:

comment this line:

load-module module-switch-on-port-available

in this file: /etc/pulse/default.pa

one person (in 2015) said it didnt help. so i didnt try it at first.

i still think compiling iceweasel-uxp without the requirement for pa would be ideal though. no one wants their browser to require it, when it was an option until the mozilla devs got lazy or simply more bent on destroying the last advantages of their browser.

people always talk about the year of the (gnu)/linux desktop. that year was 2013-- after that, are the years of the broken gnu/linux desktop. but we wouldnt be here unless we believed we can get it working again.

this time, watch out for things like dbus, udev, pa, and other freedesktop garbage becoming relied on too much. if you dont want a second systemd, you have to look at how we got there-- and then not do that.

i promise though, that none of this was a setup. i really had decided that removing speakers was the easy way (used to be easier-- i couldnt find a connector to detach like there commonly used to be) and i really had tried to find a solution and come up empty.

only im a stubborn person who sometimes doesnt really try until after hes given up two or three times. so theres some answer now. maybe itll work reliably. if its from lennart, im guessing not. if something works well and works reliably-- he can fix it.