1 (edited by ΙΧΘΥΣ 2018-01-05 12:54:53)

Topic: Errors encountered in a new installation.

Hi there,


First of all I would like to congratulate the Hyperbola developers for the great work that they are carrying out in building this new distro. I wish they are succesful in all their objectives related to this project. I also would like to give Emulatorman and coadde my most sincere condolence for the recent loss of their father who will be always be remembered with great affection by people like me approaching the Hyperbola or Parabola operating systems.

Several days ago I tried to install Hyperbola in my laptop. I attempted to follow the guide provided in your web for installing it with full disk encryption. I was not sure if I was going to be successful because I am quite an apprentice in what it refers to using Linux and the command line. After having devoted some time in trying to achieve this target, it seems to me I that I have been able to install Hyperbola with a full disk encryption.

The system works quiet well in my laptop and I am greatly satisfied with it, however it seems I made some mistakes during the installation so now I find some errors that I am not able to solve. They do not seem to be critical errors as everything in the system continous running quite well.


-One of the errors that I find is that I am not able to boot without having the live CD inserted in the optical drive. If I have not the CD inserted, Libreboot appears but after that nothing happens. If if have the CD installed I find:

error: disk 'ata0' not found.
error: disk 'lvm/matrix-rootvol' not found.
error: disk 'lvm/matrix-boot' not found.
Attempting to decrypt master key...
Enter passphrase for ahci0, msdos1 (and here is the UUID of my sda):

After that I enter the encryption password. And it continues as it follows:

Slot 0 opened
error: disk 'ata0,1' not found.
error: no such partition.
error: disk 'ata0,2' not found.
error: no such partition.
error: disk 'ata0,3' not found.
error: no such partition.
error: disk 'ata0,4' not found.
error: no such partition.
error: disk 'ata0,5' not found.
error: no such partition.
error: disk 'ata1,1' not found.
error: no such partition.
error: disk 'ata1,2' not found.
error: no such partition.
error: disk 'ata1,3' not found.
error: no such partition.
error: disk 'ata1,4' not found.
--MORE--

I have to press multiple times --MORE-- for some of these errors to appear.

error: disk 'ata1,5' not found.

After that it goes to another new screen and:

error: file '/boot/grub/fonts/unicode.pf2' not found.
error: terminal 'console' not found.
--MORE--

Afer that Hyperbola references appear and after some lines I am prompted again to enter my encryption password.

After that I find the user login screen and I am able to initiate a session. The whole process of booting takes several minutes and in no manner I am able to enter this process if I have not the live CD inserted in the optical drive. After booting I am able to remove the CD and the system continues running.


-Another error that I found was related to the Antonio Rojas' keys inside the Arch keyring. This problem dissappeared after I run some command that I found on Internet for refreshing the keys.


-Another error that I find is on the section of add ons of Iceweasel. I installed Noscript, uBlock and the No-resource-uri-leak extensions from the terminal. In the Iceweasel Add-ons section it appears on the top of the Noscript and uBlock add-ons:

Noscript could not be verified for use in Iceweasel. Proceed with caution


-Iceweasel-hardened is not able to be used inside Firejail (firejail iceweasel-hardened):

Your Iceweasel profile cannot be loaded. It may be missing or innaccessible.


-The bottom in my laptop to switch on/off the wireless function is not working and I do not find neither another option for turning it down inside the system.


-In the beginning I installed the XFCE desktop envrionment because I was not able to install any other. Not because the installation did not allow me to do that, but it seems because my lack of knowledge about how to turn systemd commands to OpenRC ones did not allow me to proceed. After that I found some commands in Internet for changing the desktop environment so I installed MATE instead. After changing from XFCE desktop environment to MATE I find the following errors:

--I am not able to find inside the terminal any longer the iceweasel package. Nor any of the packages that Iinstalled while I was using the XFCE desktop environment.

error: target not found: iceweasel

--There is no Shutting down bottom. If i want to power off the computer I need to use the terminal or otherwise logging out my user to find an option to do so.


I thank you in advance for any comment regarding these errors. I hope that this post can be of some help for someone facing the same errors in the future.

Again, greetings to the community and congratulations to the developers for the fantastic work.

2 (edited by zapper 2018-01-05 22:27:59)

Re: Errors encountered in a new installation.

I find it surprising that you cannot install iceweasel. I you see, have also done Full Disk Encryption. I did however have one bit of advice for you.

Read this thread in case you haven't configured everything: https://forums.hyperbola.info/viewtopic.php?id=25

As for noscript, I usually add it manually as it will almost always be up to date that way...

Iceweasel however is already hardened whenever you open it. If I am not mistaken.

Start from the link below and read the 8th and 9th post.

https://forums.hyperbola.info/viewtopic … d=203#p203

They helped me majorly.  I owe it to Aether that I was successful in my installation.

If you have already done this, disregard my response with the exception of installing noscript manually.

Hyperbola:

The Stable Secure Libre Arch!

3

Re: Errors encountered in a new installation.

Thanks Zapper, your reply was very useful to me when I read it.

I have used your recommendation in a recent post that I posted in the forum.