Topic: Network/browser connection issues. And the fix.

These networking things appear, sometimes. But I may have found the fix for the browser one. Maybe all these issues.

1st error.

error failed retrieving file 'libkeybinder3-0.3.2-2-x86_64.pkg.tar.lz' from mirror.cedia.org.ec : error:02FFF068:system library:funx(4095):Connection reset by peer

after trying to install peek

It installed peek, I think, but I do not know if it works yet, as I did not have much to record yet. So maybe it was just that mirror that is having problems.

But I do not think I had this error when installing vlc.

2nd error.

[Error resolving "trisquel.info": No address associated with hostname]

showed in badwolf browser on Hyperbola. But this error did not happen in Abrowser on Trisquel.
So I do not think it is the site, though it could be. The pureos.net site may also have this issue.
But I can get to sites like https://hyperbola.info and gnu.org with lynx and badwolf when I was using Hyperbola.

I also tested it with lynx in the LXTerminal when using Lumina with lumina-extra also installed and just lynx, I think, in the Hyperbola text only command line. As I think that is what starts up first on Hyperbola.

I saw

Alert!: Unable to connect to remote host.

lynx: Can't access startfile https://trisquel.info

I can get to https://trisquel.info
with the lynx on Trisquel as well as https://hyperbola.info.

3rd error.

This error reminds me of when I was trying to install Hyperbola, as sometimes I got past the

Internet Connection

part and sometimes I could not get a internet connection.

At first it may have worked in the installer, to get an internet connection with wifi, but if I quit before I installed Hyperbola, and powered off my computer, the next time I tried the installer it showed a similar error.

This may or may not have been me typing in something different than the first time I tried to install Hyperbola.
But I did get Hyperbola to install on my computer after some attempts now.

https://wiki.hyperbola.info/doku.php?id … redirect=1

I thought only issue 2, the browser one, may still be an issue, but than I found the fix. It was likely my mistake.
I was used to just clicking on the Mate desktop network thing to turn on wifi/network, but I did not know what it did as I did not know what was being turned on other than the networking and wifi, somehow.

When using Hyperbola I mostly was first logging in as root, to start/use

ip link set wlp2s0 up


wpa_supplicant -B -i wlp2s0 -c <(wpa_passphrase "SSID" "Password_here")

than logging out of root and logging in to my other account.

I could get to https://hyperbola.info after that but not https://trisquel.info

But I did not also start/use

dhcpcd wlp2s0

as root.

After I used

dhcpcd wlp2s0

as root, logged out, and into my other account, both badwolf and lynx could get to https://hyperbola.info and https://trisquel.info and likely other sites as well in my other account.

If anyone also has/had this problem/issue I hope the above information can help.


Re: Network/browser connection issues. And the fix.

You should always check the current date of the system running as you are mixing several problems into the common "network issue", which is not complete correct. Please refer: https://wiki.hyperbola.info/doku.php?id … ystem-date

Thread closed!

Human being in favor with clear principles and so also for freedom in soft- and hardware!

Certainly anyone who has the power to make you believe absurdities has the power to make you commit injustices: For a life of every being full with peace and kindness, including diversity and freedom. Capitalism is destroying our minds, the planet itself and the universe in the end!