1

Topic: licenses: key "5AA99D86E1AC7510" is unknown Fomm Oberon <Urano>

I am unable to upgrade Hyperbola GNU/Linux-libre on one computer:

[root@marketing louis]# pacman -Su
:: Starting full system upgrade...
:: Replace ffmpeg2.8 with extra/ffmpeg? [Y/n] y
:: Replace gnupg with core/gnupg-stable? [Y/n] y
:: Replace iceweasel-esr with extra/iceweasel-uxp? [Y/n] y
resolving dependencies...
looking for conflicting packages...
:: your-freedom and schroedinger are in conflict. Remove schroedinger? [y/N] y

Packages (64) arch-keyring-20181222-0  cronie-1.5.1-1.hyperbola5  dhcpcd-6.11.5-1.hyperbola2  elogind-232.6-4  emacs-25.3-3.hyperbola1
              eudev-3.2.5-4  evince-3.24.0-1.hyperbola2  ffmpeg-1:3.3.8-5.hyperbola2  ffmpeg2.8-2.8.11-6 [removal]
              filesystem-2017.03-2.hyperbola10.4  gcc-6.3.0-1.hyperbola2  gcc-libs-6.3.0-1.hyperbola2  git-2.12.2-4.hyperbola5
              gnupg-2.1.23-1.hyperbola2 [removal]  gnupg-stable-2.2.8-2.backports1  gpm-1.20.7-7.hyperbola3  grub-2:2.02-1.hyperbola4
              hwids-20180917-1.hyperbola0  hyperbola-keyring-20181222-0  iceweasel-esr-1:52.8.0esr.deb1~deb9u1-1 [removal]
              iceweasel-uxp-52.9.20181218-1  inetutils-1.9.4-5.hyperbola4  libassuan-2.5.1-1.hyperbola1.backports1  libelogind-232.6-4
              libeudev-3.2.5-4  libldap-2.4.46-2.hyperbola1  libupnp-1.6.25-1.hyperbola1  libutil-linux-2.29.2-2.hyperbola3
              libwbclient-4.5.8-1.hyperbola5  licenses-20140629-2.hyperbola3  linux-libre-lts-4.9.153_gnu-0
              lm_sensors-3.4.0-2.hyperbola4  logrotate-3.12.1-1.hyperbola5  man-db-2.7.6.1-2.hyperbola2  mdadm-4.0-1.hyperbola5
              mkinitcpio-23-1.hyperbola3.3  mlocate-0.26-6.hyperbola6  mpv-1:0.25.0-2.hyperbola4  mutt-1.10.1-1.hyperbola1.backports1
              netifrc-0.6.0-4.backports1  openrc-0.28-20  openrc-sysvcompat-0.28-20  pacman-5.0.2-2.hyperbola9
              pacman-mirrorlist-20190129-1.hyperbola0  polkit-0.113-1.hyperbola5  schroedinger-1.0.11-3 [removal]
              shadow-4.5-4.hyperbola6  smbclient-4.5.8-1.hyperbola5  smplayer-17.4.2-1.hyperbola3  usbutils-010-1.hyperbola1
              util-linux-2.29.2-2.hyperbola3  vlc-3.0.4-3.hyperbola1.backports1  wget-1.19.5-1.hyperbola1
              wpa_supplicant-1:2.6-11.hyperbola3  xorg-fonts-misc-1.0.3-5.hyperbola1  xorg-server-1.19.6-2.hyperbola1
              xorg-server-common-1.19.6-2.hyperbola1  xorg-server-devel-1.19.6-2.hyperbola1  xorg-server-xdmx-1.19.6-2.hyperbola1
              xorg-server-xephyr-1.19.6-2.hyperbola1  xorg-server-xnest-1.19.6-2.hyperbola1  xorg-server-xvfb-1.19.6-2.hyperbola1
              xorg-server-xwayland-1.19.6-2.hyperbola1  your-freedom-20190103-0

Total Installed Size:  807.96 MiB
Net Upgrade Size:       -7.24 MiB

:: Proceed with installation? [Y/n] y
(60/60) checking keys in keyring                                                  [###############################################] 100%
downloading required keys...
:: Import PGP key 1024D/328E93B83AF8ED58EA6556171583217AE1AC7510, "Fomm Oberon <Urano>", created: 1999-02-27? [Y/n] 
:: Import PGP key 1024D/328E93B83AF8ED58EA6556171583217AE1AC7510, "Fomm Oberon <Urano>", created: 1999-02-27? [Y/n] y
(60/60) checking package integrity                                                [###############################################] 100%
error: arch-keyring: key "5AA99D86E1AC7510" is unknown
:: Import PGP key 1024D/328E93B83AF8ED58EA6556171583217AE1AC7510, "Fomm Oberon <Urano>", created: 1999-02-27? [Y/n] y
:: File /var/cache/pacman/pkg/arch-keyring-20181222-0-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: filesystem: key "5AA99D86E1AC7510" is unknown
:: Import PGP key 1024D/328E93B83AF8ED58EA6556171583217AE1AC7510, "Fomm Oberon <Urano>", created: 1999-02-27? [Y/n] y
:: File /var/cache/pacman/pkg/filesystem-2017.03-2.hyperbola10.4-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: hwids: key "5AA99D86E1AC7510" is unknown
:: Import PGP key 1024D/328E93B83AF8ED58EA6556171583217AE1AC7510, "Fomm Oberon <Urano>", created: 1999-02-27? [Y/n] y
:: File /var/cache/pacman/pkg/hwids-20180917-1.hyperbola0-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: hyperbola-keyring: key "5AA99D86E1AC7510" is unknown
:: Import PGP key 1024D/328E93B83AF8ED58EA6556171583217AE1AC7510, "Fomm Oberon <Urano>", created: 1999-02-27? [Y/n] y
:: File /var/cache/pacman/pkg/hyperbola-keyring-20181222-0-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: iceweasel-uxp: key "5AA99D86E1AC7510" is unknown
:: Import PGP key 1024D/328E93B83AF8ED58EA6556171583217AE1AC7510, "Fomm Oberon <Urano>", created: 1999-02-27? [Y/n] y
:: File /var/cache/pacman/pkg/iceweasel-uxp-52.9.20181218-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: licenses: key "5AA99D86E1AC7510" is unknown
:: Import PGP key 1024D/328E93B83AF8ED58EA6556171583217AE1AC7510, "Fomm Oberon <Urano>", created: 1999-02-27? [Y/n] 

And so on, and so on.

So who can help me do the right way?

I have already refreshed the keys.

2 (edited by aloniv 2019-03-05 09:30:59)

Re: licenses: key "5AA99D86E1AC7510" is unknown Fomm Oberon <Urano>

After fetching all the packages you can install them without verification using this command (just make sure the /var/cache/pacman/pkg folder does not contain multiple versions of the same package):

sudo pacman -U /var/cache/pacman/pkg/*.tar.xz

You should perform updates regularly (preferably at least once a week) to prevent such problems from occurring (iceweasel-uxp was released in November).

3

Re: licenses: key "5AA99D86E1AC7510" is unknown Fomm Oberon <Urano>

aloniv wrote:

After fetching all the packages you can install them without verification using this command (just make sure the /var/cache/pacman/pkg folder does not contain multiple versions of the same package):

sudo pacman -U /var/cache/pacman/pkg/*.tar.xz

You should perform updates regularly (preferably at least once a week) to prevent such problems from occurring (iceweasel-uxp was released in November).

Hmm... I didn't think it was needed to do that. I just upgraded, cause I felt like it. :0

But yeah, Always be burning isos to your preferred medium, aka usb or cd rom, etc... because I tried to use milky way 2.4 when 2.6 was released and I could not install at all. xD

Hyperbola:

The Stable Secure Libre Arch!